Reply
Posts: 61
Registered: ‎11-04-2016

Si5351 strange phase behaviour

I am using two OCXO. First of all I programmed Si5351 produce 10.000000 MHz output from 10.0000000 Mhz input, wanted observe frequency offset between two OCXO. I observed  about 0.25 Hz defference , because phase offset turn around about 4s time by 2PI. It is OK. So I programmed Si5351 produce 10 MHz + 0.025 ppm frequency . I was very surprised by the result.. It seems like Si5531 "corrects" phase shift perdiocally (?) not continuously. I can see phase changing from zero to 2 PI offset every time.. But frequency yes, 10 MHz + 0.025 ppm Robot Happy Is it normall for multysynth or my fault?

Highlighted
<a href="http://community.silabs.com/t5/Welcome-and-Announcements/Community-Ranking-System-and-Recognition-Program/m-p/140490#U140490"><font color="#000000"><font size="2">Hero</font></font> </a> jmg
Posts: 1,174
Registered: ‎04-27-2004

Re: Si5351 strange phase behaviour


 So I programmed Si5351 produce 10 MHz + 0.025 ppm frequency . I was very surprised by the result.. It seems like Si5531 "corrects" phase shift perdiocally (?) not continuously. I can see phase changing from zero to 2 PI offset every time.. But frequency yes, 10 MHz + 0.025 ppm Robot Happy Is it normall for multysynth or my fault?


What does the Frequency plan report say ?

The fractional parts of that, will indicate how it applies the correction, and yes, it will average to the expected frequency, but as it is a M+N/O  calculation, there is contained in the N/O a digital quanta on the phase.

0.025ppm is quite small,  but with two OCXO's I'd expect that to be visible.

If you want to have no phase effects at all, you probably need VCTCXOs and some analog adjustments.