Reply
Highlighted
Posts: 135
Registered: ‎12-06-2016
Accepted Solution

wrong path with IAR

IAR and Studio are on C:

I first worked on C:

because of memory problems I defined a new Projekt on E:

Now I get a lot of not found like:

 

Fatal Error[Pe1696]: cannot open source file "E:\SiliconLabs\SimplicityStudio\v4\developer\stacks\ble\v2.1.1.0\platform\emlib\src\em_cryotimer.c"

 

Looks like the IAR changes everthing to E: instead of C:

Where can I change this ?

Thanks

arnold

Posts: 263
Registered: ‎12-05-2016

Re: wrong path with IAR

Hi @zender64,

 

Did you define a new workspace to be on the  E: before you created the project?  The project must reside within the current workspace directory.  If you didn't, and the project still needs to reside on E:, please create a workspace there and then import the existing project(s) using [File] > [Import] > [General] > [Existing Projects into Workspace] (the same could be used to import the project to a workspace on the C: drive).  Assuming that isn't the issue, the path to the toolchain is defined at [Window] > [Preferences] > [Simplicity Studio] > [Toolchains], please make sure that points to the correct location.  Also in the [Project] > [Properties] > [Resource] [Linked Resources] there should be a Path Variable - STUDIO_TOOLCHAIN_LOC that should point to the IAR installation.

 

Thank you,

jpitt