Reply
Posts: 18
Registered: ‎04-20-2017
Accepted Solution

"unable to download asset" error

Installed some updates to Simplicity Studio today.  Now when I try to open an application note I get the above error.  If I click on details it shows that Simplicity Studio is searching for the app note on my hard drive which of course fails.  Is there a setting to tell Simplicity Studio to download this from the internet if it is not located on the local disk?  This all worked as expected before today's updates.

 

Error message is attached.

 

Thanks

 

Posts: 581
Registered: ‎12-05-2016

Re: "unable to download asset" error

Hi @DonT,

 

 

That particular AN (AN0007) seems to have issues, I get the same error when I try to download it, but I can download other ANs without any problem.  Can you try and download a different AN and let me know if you are able to? (for instance I was able to download AN0002, AN0003 and AN0005).  And for AN0007, it actually downloaded correctly for me, there is just a bad name in the set of assets associated with that AN.  Opening File Explorer and looking in the [STUDIO_INSTALLATION_FOLDER]/offline/efm32/appnote directory there is a folder called "an007_efm32_energymodes" with all of the related files.  The filename should be either "an007.0-efm32-ezr32-series-0-energymodes.pdf" or "an007.1-efr32-efm32-series-1-energymodes.pdf"  but apparently there is a link specifying for an0007-efm32-energymodes.pdf in the asset definitions.  I will report this bug to get it fixed.

 

Thank you,

jpitt

Posts: 18
Registered: ‎04-20-2017

Re: "unable to download asset" error

You are correct, I tried another app note and it downloaded without issue.  Sorry I jumped to the wrong conclusion and blamed the update. 

 

Thanks.