Reply
Highlighted
Posts: 13
Registered: ‎02-14-2017

compatible debug agent not found

[ Edited ]

When launching debug I get a error message no compatible sub agent found

under launcher Hardware I see two segger tools listed the J-Link plus showing the correct serial number of the device

and the std J-Link device. both items show the STK3800A board as a sub folder for wonder gecko .

i have tried launching debug under both and get the same error message

I have changed the debug mode from MCU to out reset the board and the j-link plus still get the same error

Is this a problem with simplicity studio 4 or the debugger / driver?

anyone have this problem in the past , or know of a solution?

 

 

Posts: 1,955
Registered: ‎10-14-2014

Re: compatible debug agent not found

@molrich1

I am a little bit confused with your description, could you help clarify?

1. are you using the Wonder Gecko STK from silabs (STK3800) to debug your own board?

2. or you are using J-Link plus to debug some Silabs EFM32 device?

3. do you mind to upload the screenshot of the simplicity studio launcher perspective? I think y you are using the simplicity Studio V3. if possible maybe a Simplicity Studio log file helps to troubleshooting this issue.

4. What do you mean by "launcher hardware". I did see where I could made a view named "launcher hardware" showed up on my side.

 

My views are my own and do not necessarily represent the views of Silicon Labs

 

WeiguoLu
Posts: 13
Registered: ‎02-14-2017

Re: compatible debug agent not found

at this point I am trying to connect to a STK3800 board using the onboard debug header

 

I have attached screen shots and the log file

I am using the Simplicity Studio V4

Posts: 1,955
Registered: ‎10-14-2014

Re: compatible debug agent not found

[ Edited ]

---------------

at this point I am trying to connect to a STK3800 board using the onboard debug header

-----------------

I am still little bit confused,

a. do you mean you are using a standalone J-Link plus debugger to connect the debug header of the STK3800 board?

b. there is an integrated J-Link debugger on Wonder Gecko STK STK3800. You could connect the USB mini port on the STK3800 to debug the board/MCU and don't need a standalone debugger.

Please check the user guide of the STK board as below:

http://www.silabs.com/documents/public/user-guides/efm32wg-stk3800-ug.pdf

c. After I connected the mini USB port of my STK3800, I see below picture under devices tab in launcher perspective.

J-link.png

you should see "J-Link Silicon Labs" instead of "J-Link Plus".

My views are my own and do not necessarily represent the views of Silicon Labs

WeiguoLu
Posts: 13
Registered: ‎02-14-2017

Re: compatible debug agent not found

yes, I have a stk3800. I have a standalone Jlink plus as well to assist in bringing up my own hardware - but are not at that point yet. 

If I try to debug with either interface I get a " no compatible debug agent found " message.

 

when I plug in the mini usb i see a j link silicon Labs icon 

jlink.png

 

but, when I launch debug mode I get the following error message

error_msg.png

 

 

Posts: 322
Registered: ‎12-05-2016

Re: compatible debug agent not found

Hi @molrich1,

 

The Debug Mode: OUT is to be used when connecting a custom board or other external board to the WSTK through the debug header on the board.  When using the SOC that is installed on the development board the Debug Mode must be set to MCU.

 

Thank you,

jpitt

Posts: 13
Registered: ‎02-14-2017

Re: compatible debug agent not found

thanks, 

I do have the debug mode set to MCU.

debug_mode.png

Posts: 13
Registered: ‎02-14-2017

Re: compatible debug agent not found

I am still not able to debug with in Simplicity Studio version 4. I am still getting an error message no compatible debug agents found. Has anyone else found a solution to this problem?

 

Posts: 322
Registered: ‎12-05-2016

Re: compatible debug agent not found

Hi @molrich1,

 

From the Launcher perspective, if the "Getting Stated" tab is selected instead of "Compatible Tools" as in the last picture posted, please click the STK3800_blink form the Software Examples column.  Click [Yes] when Studio prompts "Would you like to switch to Simplicity IDE perspective and create this Example Project now?".  Then click the hammer (build) icon to build the project and then the bug icon to debug the project.  Does that successfully download the application to the board and launch the debugger?

 

Thank you,

jpitt

Posts: 13
Registered: ‎02-14-2017

Re: compatible debug agent not found

following your steps, the following occurred

1) initially the build would not complete.

Could not find file "mbed.h"

2) added path to directory were mbed.h existed, still received compile error

3) removed include mbed.h and compile worked

Launched debug and received the same error message  - compatible debug agent not found