Reply
Highlighted
Posts: 457
Registered: ‎06-01-2012

USB connection/debugging problem with the STK/DK

Q: When trying to debug the Starter/Development Kit, the J-link debugger is not found, the board is not found, or the USB will not enumerate.

A:

1) Make sure you have Simplicity Studio installed and up to date as described here. The energyAware Commander package must be installed in Simplicity Studio as a minimum.

2) Make sure you have the SEGGER J-link driver installed. You can get this at http://www.segger.co...k-software.html. Latest version of simplicity studio will install this automatically.

3) Connect the development kit or starter kit to your PC and power it on.

4) Start energyAware Commander in Simplicity Studio and click Connect

3) Find out if there is a problem with with the USB connection:

- In energyAware Commander, check if Debug Mode 'MCU':

- Disconnect and reconnect the usb-cable, toggle the power switch.

- Make sure the usb address is configured correctly. To change this, use the J-link commander from segger and type 'usbaddr 0'

to set it back to 0, which is default. The J-link commander should print something like this if it is able to connect to the board:

(Dates, serial number, Vtarget and such is of course different from board to board)

---------------------------------------------------------------------------

SEGGER J-Link Commander V4.14g ('?' for help)

Compiled Jul 27 2010 17:19:10

DLL version V4.14g, compiled Jul 27 2010 17:18:55

Firmware: Energy Micro EFM32 compiled Aug 26 2010 17:20:28

Hardware: V7.00

S/N : 94500198

Feature(s) : GDB

Info: Found SWD-DP with ID 0x2BA01477

Info: TPIU fitted.

Info: FPUnit: 6 code (BP) slots and 2 literal slots

VTarget = 2.712V

No devices found on JTAG chain. Trying to find device on SWD.

Cortex-M3 identified.

JTAG speed: 100 kHz

J-Link>

---------------------------------------------------------------------------

Then type 'usbaddr 0' and hit enter:

---------------------------------------------------------------------------

J-Link>usbaddr 0

USB address successfully changed to '0'.

Please unplug the device, then plug it back in.

J-Link>

---------------------------------------------------------------------------

- In the energyAware Commander change the J-Link Device to 'USB #0' (next to 'Connect' button). Try rebooting or using a different computer if you still can't connect to the kit.



3: If ping works and the mode is set correctly, but debugging still doesn't work. Make sure you have the correct settings in IAR EWARM.

You need to make sure that the IAR EWARM project settings are correct for the STK/DK with respect to the on-board J-Link.

- Under Project -> options the settings for the debugger should look something like this;

iar_settings.JPG

- If you don't have any other J-Links connected to your PC, the STK/DKs USB address is normally 0. You also need to use SWD.

Make sure that the Driver setting under 'Debugger' is set to 'J-Link'.