Reply
Posts: 27
Registered: ‎04-14-2017
Accepted Solution

Simplicity Studio Debug OUT option

Hi

 

I've tried re-installing everything but I don't get the option in Simplicity Studio to set debug mode to out

for EFR32BG1B.

 

Using Windows 7,  Simplicity Studio V4, J-Link V6.14.

 

I've updated the Radio board to the newest version inside the Silicon labs folder.  Using the the

STK/WSTK Debug Apapter to a Tag-Connect Interface.  I can detect the chip in debug mode out

in commander.exe and could compile and debug thte custom board in IAR trial version.

 

Pictures attached.

 

Thanks.

Posts: 518
Registered: ‎12-05-2016

Re: Simplicity Studio Debug OUT option

Hi @Demo,

 

Can you share what is displayed in the "Devices" window?  Is a Silicon Labs Wireless STK board (BRD4001A) attached to the computer? One picture shared is for the Solutions window and the other shows a device configuration that shows the attached board has the J-Link configuration in USB mode instead of "Serial number" mode.  Normally the device configuration window would have 4 different tabs, Application images, Adapter configuration (this is where the Debug Mode can be set), J-Link Configuration and Device hardware.  The screenshot shows that only the Device hardware tab is being displayed.

 

It would also probably be helpful to generate a zip file of the Simplicity Studio Logs - [Help] > [Report Bug...] make sure "Export Simplicity Studio log files" is selected, then hit [Next] twice and [Finish] and upload the resulting zip file to either this forum thread or else to a support case created through your Silicon Labs account.

 

Thank you,

jpitt

Posts: 27
Registered: ‎04-14-2017

Re: Simplicity Studio Debug OUT option

Hi jpitt

 

Finally figured it out after getting some errors when trying to Debug in Simplicity Studio. 

Avast anti-virus deletes the "siagentarm.exe" and "inspect_emdll.exe" for some reaston.

Causing those tabs not to be generated.

 

Will return the Blue Gecko board to Serial Number mode.  Thank you.

Highlighted
Posts: 518
Registered: ‎12-05-2016

Re: Simplicity Studio Debug OUT option

Hi @Demo,

 

Thanks for posting your solution.  There have been several reports of AVG and Avast (apparently owned by the same company) anti-virus software quarantining those adapter pack executables.  From within the anti-virus software the files can be restored from quarantine.  This appears to be an issue that AVG has acknowledged and fixed: https://support.avg.com/answers?id=906b0000000DvETAA0 That linke says the program has to be updated as well as the virus defintions.

 

I also installed AVG on a laptop at my home last week and I then installed Simplicity Studio and the files weren't quarantined.  Also another customer reported that after they updated the virus definitions for Avast it no longer detected those files as malware, so it does appear this issue has been fixed.

 

Thank you,

jpitt