Reply
Posts: 5
Registered: ‎04-06-2017

Simplicity Studio 4 won't run

Hi,

 

I'm working on a Windows 7 system, and I've had great success using Simplicity Studio 4 on this box in the past.

 

Today, I planned to begin work on a new project, so I opened SS and chose to check for updates. A lot of updates were downloaded and presumably installed, and then I was asked to restart SS, which I did. After the restart, I got the splash screen and then the application window appeared briefly, after which the entire application closed. I rebooted my computer, but got the same results.

 

I then completely uninstalled SS and reinstalled it fresh from the SL website, but that didn't fix things, either. I also added '-clean' to the command line and tried running as administrator, but neither of those things worked.

 

I every case the splash screen appears, followed by the application window, which hangs around for maybe 3 seconds, and then just disappears. Nothing shows in task manager, so it looks like it's just shutting itself down.

 

I'm attaching the .log file from the .metadata directory in  c:\Users\..\SimplicityStudio\v4_workspace.

 

Can anyone help me out here?

 

Thanks in advance for your help,

 

Mike Holmes

 

 

 

 

Posts: 5
Registered: ‎04-06-2017

Re: Simplicity Studio 4 won't run

Just a bit more background info:

 

I'm running Windows 7 Professional SP1, and I'm current on updates.

 

The host computer is a Dell / Intel Core i7-2620M @2.70 GHz with 8GB of RAM and 77 GB of free disk space.

 

Thanks again,

 

Mike

Posts: 210
Registered: ‎12-05-2016

Re: Simplicity Studio 4 won't run

Hi Mike,

 

I'm sorry for the difficulty with updating Simplicity Studio.  The log file that was attached doesn't give details on the actual crash, but it does give a few hints of some initial steps to make in recovering operations.  The logs indicate that the Silicon Labs password has expired.  Please:

1. Go to www.silabs.com and Log In to change your Silicon Labs password.

2. Delete the file secure_storage at C:\Users\Mike\.eclipse\org.eclipse.equinox.security

3. Zip up any .log files in the directory C:\SiliconLabs\SimplicityStudio\v4\configuration and attach those to this forum thread.  I believe there will be some hs_err_pid*.log files that are the JVM crash logs.

4. Simplicity Studio was obviously crashing before adding the -clean option to the command line, but there are errors saying that the ModuleCleanupAddon can't be retrieved, so remove the -clean option.

 

It is possible that after performing step 2 and 4 Simplicity Studio will start up, but if not the crash logs will give us a clue as to what is happening.

 

Thank you,

jpitt

Posts: 5
Registered: ‎04-06-2017

Re: Simplicity Studio 4 won't run

Hi jpitt,

 

I really appreciate your taking the time to respond.

 

Per your instructions, I changed my SL password, deleted the secure_storage file, and removed the -clean CL option. I could not find any *.log files in the directory you specified.

 

I then attempted to restart SS, but the same thing happened again.

 

Is there any other possible places I should look for crash logs?

 

Thanks for your help,

 

Mike

 

Posts: 210
Registered: ‎12-05-2016

Re: Simplicity Studio 4 won't run

Hi Mike,

 

A couple of other places you could look:

1. C:\Users\Mike\SimplicityStudio\v4_workspace\.metadata

2. C:\Users\Mike\SimplicityStudio\v4_workspace\outgoing

3. C:\SiliconLabs\SimplicityStudio\v4\.metadata (this directory might not exist).

4. Use File Explorer to search the C: driver for hs_err_pid*.log files or open a command prompt and type dir /s/b c:\hs_err_pid*.log

 

Another thing you could try is to use a text editor to edit the file C:\SiliconLabs\SimplicityStudio\v4\studio.ini and add -debug as the first line.

Then when starting Simplicity Studio a command prompt window will be opened with log messages in it, those messages might give us a clue as to why Simplicity Studio isn't starting.

 

If you upload the .log file again it should have new information after you deleted the password and ran without the -clean option.

 

Thank you,

jpitt

Posts: 5
Registered: ‎04-06-2017

Re: Simplicity Studio 4 won't run

I found the JVM crash logs. They were in the v4 directory. Sorry I didn't look harder the first time.

 

Also attaching the newer startup log file.

 

I tried the -debug option, but the debug window disappeared so quickly that I wasn't able to discern anything meaningful.

 

Thanks again,

 

Mike

Posts: 210
Registered: ‎12-05-2016

Re: Simplicity Studio 4 won't run

Hi Mike,

 

Sorry for all the experiments, the crash logs do look similar to some others we have seen recently.  Can you try renaming your Simplicity Studio workspace (C:\Users\Mike\SimplicityStudio\v4_workspace).  So don't delete it, but just rename it and then start Simplicity Studio again.

 

Thank you,

jpitt

Posts: 5
Registered: ‎04-06-2017

Re: Simplicity Studio 4 won't run

Hi jpitt,

 

I renamed c:\Users\Mike\SimplicityStudio\v4_workspace to "renamed_directory" and restarted SS, but this did not fix the problem.

 

A new v4_workspace directory was created, and I'm attaching the log file from it as well as the latest JVM log.

 

Thanks,

 

Mike

Posts: 5
Registered: ‎03-12-2017

Re: Simplicity Studio 4 won't run

Hi All,

 

Has there been any resolution to this problem with SS 4 won't start?

 

I have the exact same symptoms.

 

Regards,

Tom.

Posts: 5
Registered: ‎03-12-2017

Re: Simplicity Studio 4 won't run

Hi again,

 

Forgot to add zip folder containing log file and error logs.

 

Cheers,

Tom.