Reply
Highlighted
Posts: 30
Registered: ‎03-24-2016

EFM8UB2_USBXpress_{Echo,TestPanel} Linux Compile Problems

Same path name problems as VCPXpress. See Linux VCPXpress Compile Problems

plus the debugger had the wrong idea of the path to usb_0.c. I forget what the debugger though it was, but here's what it should be (relative to SimplicityStudio_v4 installation directory):

./developer/sdks/8051/v4.0.8/Device/EFM8UB2/peripheral_driver/src/usb_0.c

 

I also tried to compile EFM8UB2_USBXpress_TestPanel sample project. In main.c I find:

* This example communicates with the TestPanel Windows application installed
* by the USBXpress SDK (typically installed at:
* C:\SiliconLabs\MCU\USBXpress_SDK\Examples\TestPanel\Host\Windows).

which does not exist. I was able to find something close, installed as:

./developer/sdks/8051/v4.0.8/examples/EFM8UB1_SLSTK2000A/USB/USBXpress/EFM8UB1_USBXpress_TestPanel

but nothing for my EFM8UB2 board. Is there a Linux version of the host TestPanel application available for download somewhere?

 I ran the testpanel sample in the debugger, and found it to be in a routine checking for USB device suspended. When I hit "Step Return", the debugger showed this in its console:

Can't find a source file at "C:/jenkins/workspace/EFM8_USBXpress_Release/efm8_usbxpress/lib/sdk/Lib/efm8_usb/src/efm8_usbd.c" 
Locate the file or edit the source lookup path to include its location.

efm8_usbd.c is actually in:

./developer/sdks/8051/v4.0.8/an/AN1047/SimplicityStudio/lib/efm8_usb/src/efm8_usbd.c

relative to the SimplicityStudio install directory.

 

Finally, is there any progress on the connectivity problem shown in What is siagent?

 

Thanks,

Posts: 581
Registered: ‎12-05-2016

Re: EFM8UB2_USBXpress_{Echo,TestPanel} Linux Compile Problems

Hi @bjbatten,

 

There is not a version of the host TestPanel application for Linux.  The Windows version of the program is in the USBXpress SDK which can be found in the software download section of www.silabs.com (https://www.silabs.com/products/development-tools/software?query=USBXpress ), but the program has not been ported into Simplicity Studio.  In Simplicity Studio there are various Host_Application_Software examples in the v4.0x/an directory.  I do not know if these would port or build under Linux.

 

There are some other Knowledge Base Articles and Community Forum threads that indicate USBXpress is not supported under Linux: 

http://community.silabs.com/t5/Interface-Knowledge-Base/Using-USB-MCUs-with-Linux/ta-p/112331

http://community.silabs.com/t5/8-bit-MCU/USBXpress-amp-Linux/m-p/74515/highlight/true#M30581

 

But you might get a better answer on the 8-Bit MCU forum.

 

Thank you,

jpitt

Posts: 30
Registered: ‎03-24-2016

Re: EFM8UB2_USBXpress_{Echo,TestPanel} Linux Compile Problems

Hi @jpitt,

Thanks for the link. Unfortunately (it may be old eyes) the closest I can get to the Windows TestPanel application is the release notes. I'll look around in v4.0x/an and see what I can see.

 

I posted here because the relevant problems are all to do with various typos in file name paths for the Linux version of SimplicityStudio, not EFM8 hardware itself.

 

Thanks,