Reply
Posts: 17
Registered: ‎11-01-2014

Bizarre syntax highlighting in Studio editor

Running Simplicity Studio v4 on Windoze 8.1...

 

The syntax highlighting seems to be quite random in this file.  Am I doing something to provoke this?

 

 

Posts: 582
Registered: ‎12-05-2016

Re: Bizarre syntax highlighting in Studio editor

Hi @clarkleach,

 

Is the strange syntax highlighting only being seen in the one file as suggested by your post?  If so could you please attach the file to this forum thread, so we can check if there is something strange in the file itself.

 

Thank you,

jpitt

Posts: 17
Registered: ‎11-01-2014

Re: Bizarre syntax highlighting in Studio editor

@jpitt - 

Yes, I have only seen it in this one file.  Also, it seems to start with the definition of the huge union...

FWIW - everything appears to compile fine and the program is running at this moment, so I can't attribute it to a syntax error.

 

Posts: 17
Registered: ‎11-01-2014

Re: Bizarre syntax highlighting in Studio editor

I also noticed that the code-folding seems to lose its grip at about the same point in the file...

Posts: 582
Registered: ‎12-05-2016

Re: Bizarre syntax highlighting in Studio editor

Hi @clarkleach,

 

I don't see the same thing happening when I open the file in Simplicity Studio.  I have tried on Windows 10, Windows 7 and Linux Ubuntu 16.04.  If the file is opened outside of a project context (so just saved somewhere outside the project and then opened in the Simplicity IDE) do you see the same issue?  Also is the strange highlighting in the same place each time the file is opened?

 

Thank you,

jpitt

Highlighted
Posts: 17
Registered: ‎11-01-2014

Re: Bizarre syntax highlighting in Studio editor

@jpitt - 

Well, I don't know what inspired that mess but I never got as far as opening the file outside of the project context.  I closed the file and re-opened it from the project explorer and everything looks normal again.  Can't fix what ain't broke...