Reply
Posts: 9
Registered: ‎12-22-2016

HA Sample Switch won't go sleep correctly with EmberZNet 5.7.3 using EFR32 on WSTK

Hi Everyone,

I tried to monitor my device's power usage with simplicity studio 4.0's Energy Profiler using the HA switch sample code. I have enable the EEPROM plugin according to the KB's instruction for sleepy end device.

However, from the Energy profiler's UI, the device seems not going to sleep state because the power usage is keep around 5.3 mA all the time.

 

Do you guys have any ideas that what could be the root cause?

Any hints are welcome.

Or is there any sample code to let the device(EFR32MG) going to sleep mode is also welcomeRobot Happy

 

Thank you very much.

Posts: 73
Registered: ‎04-26-2016

Re: HA Sample Switch won't go sleep correctly with EmberZNet 5.7.3 using EFR32 on WSTK

Hello Devon,

I have recently tested the sleep current on EFR32MG1 on WSTK board using the Z3 Switch sample app based on EmberZNet5.7.3GA, so I could give you the steps and you can try and see if you can get this sample app to work: 

1. Create a new project based on the Z3 Switch sample app, and make these modifications in the .isc file: 
- Under the "Znet stack" tab, change the device type to Sleepy End Device 
- Under Plugins tab, enable "EEPROM" 
- Under Plugins tab, disable "heartbeat" 
2. Generate and build the project, and upload it along with an application bootloader to the chip. The power switch on the WSTK board should be set to "AEM". 
3. Disconnect from the node in the Network Analyzer view. 
4. Power cycle the board. 
5. Start Energy Profiler, connect to the node and start profiling. You should see sleep current around 3-4 uA. 

I recommend you to test the current with our Z3Switch sample project after 5.7.3 stack.You should be getting ~3.4uA sleep current, and we have just verified this using the Z3Switch sample app (after changing device type to sleepy end device and adding the EEPROM plugin). You might also want to power-cycle the board (if you are measuring on WSTK board) after uploading the firmware. 

Best Regards,
Lei
 
Highlighted
Posts: 9
Registered: ‎12-22-2016

Re: HA Sample Switch won't go sleep correctly with EmberZNet 5.7.3 using EFR32 on WSTK

Hi Lesun,

Thanks for the reply, I think I found the possible root cause.

Actually, I am using EmberZnet 5.8.0(not 5.7.3) to built this example and it does not work.

The device is not going to sleep all the time.

 

While I change the Znet stack back to 5.7.3, it works as expected, the current is around 2.5 ua right now.

 

Not sure if there were some bugs releated to sleep end device in 5.8.0?

I have checked the release note document but cannot to find related issue.

Does anyone have ideas that Znet stack changes between 5.7.3 and 5.8.0?

 

Or can I just use 5.7.3 for developing our product?

 

Thank you very much.