Reply
Posts: 5
Registered: ‎07-22-2016
Accepted Solution

EZSP Backward Compatibility Question

We are trying to upgrade the EZSP firmware on our EM357 based devices to 5.7.2 from 4.6.1. In the process we found we would need to link to new libraries on the host side as well.

 

Currently, our host system is deployed with both EM260 and EM357 based devices. There does not seem to be a firmware image for the EM260 in the EmberZNet 5.7.2 release.

 

I was wondering if the host portion of the EZSP 5.7.2 protocol is backwards compatible with firmware that can be loaded onto the EM260?

 

Thanks

Posts: 104
Registered: ‎11-16-2015

Re: EZSP Backward Compatibility Question

Officially we only guarantee operability between the same host and NCP version and we recommend that you update your stacks and NCP images concurrently.  At minimum we suggest that you don't stray too far between versions, say a 5.4.x NCP and 5.6.x maybe 5.7.x host code.  While there are generally no issues between NCP and host code, we make no guarantees on backwards compatibility between different versions.  

In terms of the EM260 parts, their NCP support ended with the 5.0.1 stack.  It would be pretty unlikely that the 5.7.x host base would be compatible.  It would be more recommended to try a stack version closer to that.  5.4.x might be the furthest to be expected to work.  However, you might want to test out the versions to see what results you get.

Ultimately it really depends on what your upgrade is for and what type of features you want to realize.

Posts: 5
Registered: ‎07-22-2016

Re: EZSP Backward Compatibility Question

Thanks for your response Ron, that is helpful to know. We are upgrading to a newer version as we are seeing some issues with the NCP crashing and were wondering if an upgraded firmware might fix the issue.