Changing IAR Version in Simplicity Studio v4

by <a href="http://community.silabs.com/t5/Welcome-and-Announcements/Community-Ranking-System-and-Recognition-Program/m-p/140490#U140490"><font color="#000000"><font size="2">Hero Employee</font></font> </a> RonB ‎12-14-2016 04:01 PM - edited ‎12-29-2016 01:01 PM

With the newest EmberZNet 5.8.0.0 stack, Silicon Labs has updated the version of IAR which is the support compiler.  The supported version is like this:

 

EmberZNet 5.8.0.0 (and upcoming releases) - IAR Embedded Workbench 7.80.2

EmberZNet 5.7.4.1 (and prior relsease) - IAR Embedded Workbench 7.30.1

 

However, in Simplicity Studio, you can only have one version of IAR enabled at a time.  Follow these instructions to change your IAR version:

 

  1. In Studio select Window > Preferences
  2. On the Preferences window, go to the section for Simplicity Studio > Toolchains.
    IAR-Studio.PNG

  3. Click the Add Button, this will bring up the Add Toolchains window.
    IAR-Studio-2.PNG

  4. Brows to where the IAR version you want is installed.  If you have installed IAR to their default locations, they will be as follows:
    7.30.1 - C:\Program Files (x86)\IAR Systems\Embedded Workbench 7.0
    7.80.2 - C:\Program Files (x86)\IAR Systems\Embedded Workbench 7.5

  5. Hit OK on the Add Toolchains window and hit OK on the Preferences window.

  6. Your compiler should be changed.  If you find Studio still compiling with your old compiler, you will need to restart Simplicity Studio.