Reply
Posts: 6
Registered: ‎03-25-2017

cp2102n hw issue

I try currently to get my design up and running. But I'm encountering the following issue: if I plug in my thing to USB it got recognized from the computer (shows in the device manager of Windows). But it gets fast really hot. After a while it fails, probably due to the too high temperature.

After replacing the component the whole thing starts from new.

 

Another thing with the same component (not my design, but similar design) doesn't have this issue here. So I really think that I've done something wrong in my design. But i currently can't find any issues which could cause this behaviour.

 

In the attachement is a cutout of my cp2102n design. DTR + RTS is currently unconnected after the resistors. Same for TXT + RXT. RXD0 + TXD0 are connected to a 3.3V MCU. The +3.3V for the cp2102n comes from a HT7333 regulator which get's fed from VBUS. The MCU is powered from the same rail.

cp2102.PNG

Posts: 400
Registered: ‎02-21-2014

Re: cp2102n hw issue

I don't see anything terribly wrong with your schematic, but you are missing ESD protection diodes on your USB lines (D+/D- and VBUS). Maybe ESD is causing latch-up on the part, causing the pins to sink current and heat the part up? Also, the shield pin of the USB connector shouldn't be connected to ground, unless through something like a 1M ohm resistor.

 

I would take another look at the "Self-powered" wiring diagram in the datasheet to make sure everything matches up, as well.

Posts: 6
Registered: ‎03-25-2017

Re: cp2102n hw issue

hmm, yep the esd diodes will be in place on the next revision.

 

But I don't really think that the missing esd diodes are the cause for this issue. I have multiple boards with the same design plugged into different computers firstly. All the same issue.

 

I meassured the 3.3V rail on startup (feeding 5V into the input of my ht7333 regulator) and found that there are some spikes on startup. Do you think that they propably damages something in the cp2102n?

 

Because I already tried to power the cp2102n through my linear lab PSU. Same issue with drawing >150mA.

Posts: 6
Registered: ‎03-25-2017

Re: cp2102n hw issue

So, removed a big 47uF cap on the +3.3V rail and replaced the HT7333 with an AMS1117 3.3V regulator. Same behaviour. Replaced the cp2102n with a new one. I'm really out of ideas what I can do more.

Posts: 400
Registered: ‎02-21-2014

Re: cp2102n hw issue

What about a voltage divider on the VBUS pin of the CP2102n? I know on some of our devices, this is needed in self-powered mode. Otherwise, if VDD is 0V, the VBUS pin could be 5V, exceeding the maximum voltage specs from the datasheet. In your case, the 3V rail may be slow to power up, since it's going through an external voltage regulator. For a time, the voltage on VBUS may be violating our specs. Something to look into, at least.

Posts: 400
Registered: ‎02-21-2014

Re: cp2102n hw issue

Ah, yes. Look at Table 3.10. "Voltage on UART pins, GPIO, VBUS, RSTb, or any other non-power, nonUSB pin". If VDD is zero (which it will be for a time when the voltage regulator is kicking on), the maximum voltage on any of these pins, including VBUS, is VIO + 2.5V. Since VBUS is already powered at 5V at this point, this would be violating the specification. Maybe try putting a voltage divider on VBUS, as per Figure 2.6. in the datasheet to see if that helps?

 

If that doesn't solve your problem, I would suggest putting in a support ticket.

Posts: 6
Registered: ‎03-25-2017

Re: cp2102n hw issue

Made a new revision with the suggested modifications. Still the same issue. The chip get's really hot and now doesn't even get recognized.

 

Really lost the trust into silabs.. Will change to another chip if this issue can't get resolved in a short time.

Posts: 1,728
Registered: ‎10-14-2014

Re: cp2102n hw issue

@kilobyte

Are you trying the new schematic on a new device or the device that your found have the hot problem?

I am wondering if that device was somehow damaged already or not.

Do you have this issue with the new schematic with a new device if you have one?

 

WeiguoLu
Posts: 6
Registered: ‎03-25-2017

Re: cp2102n hw issue

New PCB + new CP2102N chip. 

Posts: 77
Registered: ‎10-06-2014

Re: cp2102n hw issue

Your schematic shows pin 25 PAD as open.  It should be grounded. Can you confirm?