Reply
Posts: 2
Registered: ‎05-18-2016

Si4703 tone noise in stereo mode

[ Edited ]

Hi,

I recently did a project (https://github.com/astroza/si470x) with Si4703 FM Tuner Basic Breakout from Sparkfun. It works flawless in mono mode but in stereo I get a noise tone around 4000 hz and I don't know why. The best signal I get is RSSI=50 (75 is the max). I'm using a external antenna with good reception, however, the noise tone is present in any station on stereo mode.

If you guys can help me with this I will be forever thankful.

Posts: 53
Registered: ‎01-27-2015

Re: Si4703 tone noise in stereo mode

Hi ,

How did you identify the noise tone is 4000Hz?
Can you check the audio output directly from the tuner's LOUT or ROUT pins and see whether there's the noise tone?

Posts: 53
Registered: ‎01-27-2015

Re: Si4703 tone noise in stereo mode

Hi,

How did you identify the noise tone is 4000Hz?
Can you check the audio output directly from the tuner's LOUT or ROUT pins and see whether there's the noise tone?

Posts: 2
Registered: ‎05-18-2016

Re: Si4703 tone noise in stereo mode

Hi,

 
  I have tested LOUT and ROUT and the noise is only present when the tuner is in stereo mode. I have discarded the audio capturing system because whether in mute or MONO mode, the noise is not present.
 
I attached a sample from a local station. The noise is high frequency and annoying.
 
Cheers


Posts: 4
Registered: ‎03-06-2016

Re: Si4703 tone noise in stereo mode

Hi,
I have the same issue. I have checked tone frequency on oscilloscope with FFT and it is about 5.2-5.3kHz. I have two boards and the issue is present on one of them. In my opinion the better one. Do you have this issue when sparkfun PCB is not connected to amplifier?

 

Cheers

Highlighted
Posts: 4
Registered: ‎03-06-2016

Re: Si4703 tone noise in stereo mode

Problem fixed. I had to remove a piece of ground plane. And for the future I should connect unused

GPIO (pin 19) to GND.

 

Clipboard01.png