Posts: 1
Registered: ‎03-29-2017

CP210x Installation Failure for Windows 8.1

Dear All,

I have an ICOM 7300 amateur radio with a usb connection to my PC. Am running Windows 8.1 operating system. I have in the last 4 weeks run into various issues with the Virtual Port (VP) to connect my USB to UART. I have installed drivers downloaded from the official Silicon Laboratories website. I am using the recommended CP210x drivers version for the VP and give an error message Code 10. it won't work. When l click on device manager the com virtual port allocated for the USB to UART bridge has a yellow exclamation mark. I have also reset the VID and PID as recommended in some forums.

What is interesting is that the installation has created two OEM.inf files (OEM28.inf and OEM40.inf) and both seem to be in use. I have noted that the system registry does actually recognise both files as active drivers for the silabvcp.inf. I have further tried to uninstall the Silicon Lab drivers and delete these OEM files with silabenm.sys and the associated files and fails to delete as they are in use.

I am using an HP 280 G2 Minitower business PC running Windows 8.1.

I have also tried to uninstall the silicon lab software/program and cannot be located in features and programs so that l could delete the above files manually.

Could someone with a working system advise me how you resolved this problem and advise a computer make/model and Windows OS version that will work flawlessly for USB driver installation.


I have really reached the end of my tether and would greatly appreciate any assistance/advise,

Thanks in advance and regards.


Posts: 2,384
Registered: ‎10-14-2014

Re: CP210x Installation Failure for Windows 8.1


Do you still have this issue,

do you have a chance to try open the command console and use the pnputil.exe to delete the oem.inf file?


I think this is a end product that was manufactured by a 3rd party company that has a CP210x device in it. I don't if the manufacture of this product has customized the CP2102 and need a corresponding customized driver, check if below KBs helps: