Posts: 2
Registered: ‎02-21-2017
Accepted Solution

CP210 - Windows 10 issue



I'm having some trouble installing the CP210x driver in order to connect to a board controller in a 24" ARMAGARD touch screen lcd enclosure.


In fact, the USB to UART driver isn't displayed in the Windows Device Manager but is shown in Program and Feature. I'm running Windows 10.


I tried several things like : installing legacy driver (with this method, i can see the device in COM tab, but I have an error code 10 poping up), modifying registry entries, using two other laptops running Windows 10, running a Windows 7 virtual machine, ...


I even read few forum's topics which recommends to uninstall driver by deleting files in C:/Windows/inf and C:Windows/System32/drivers and then reinstalling it... None of these solutions worked.


Don't know what to do next... Could you give me a hand please ?


Thanks a lot,


Best Regards,

Posts: 2,384
Registered: ‎10-14-2014

Re: CP210 - Windows 10 issue


Suggest you contact the manufacture of this product first to check if they have a driver for this product. The reason I made this suggestion is that product manufacturers are expected to customize/productize the CP21xx device and reference driver for their product.

The Silicon Labs reference driver is not intended for use by end customers since the CP21xx device has likely been customized and the reference driver will no longer work with the device.

For more information, please see the following knowledge base article:

You could check if the VID/PID of this product is the same as the one that used by our CP210x DK board.


 My views are my own and do not necessarily represent the views of Silicon Labs

Posts: 2
Registered: ‎02-21-2017

Re: CP210 - Windows 10 issue


Thanks a lot for your answer, will take a look to this link and contact the LCD manufacturer.

Have a nice day,