Reply
Posts: 3
Registered: ‎04-21-2017
Accepted Solution

Can't find board/part in project setup

I'm running Simplicity Studio v4. I have a WSTK PCB4001 rev A03 (ST recognizes it as a BRD4001 rev A01 board) and a Blue Gecko BGM111-A (recognizes as part BRD4300A rev A01). 

If I try to make an empty project (SOC-empty) using Bluetooth SDK (I don't know why but I actually can't use the Bluetooth Smart SDK – ST doesn't list it in the available SDKs list) I can't anymore find/select neither the appropriate board nor the part (I attach a screenshot).

Am I missing something?

What can I do to move on to my first (really basic) project?

Thanks in advance,

Luca

Highlighted
Posts: 93
Registered: ‎09-21-2016

Re: Can't find board/part in project setup

Hi Luca,

 

Rev 01 of this board is not supported any more by the Bluetooth SDK. (Bluetooth Smart SDK was renamed to Bluetooth SDK recently)

If you still want to use it, create a new Solution with BRD4300A Rev 02. You can then develop for Rev 02 and flash it to your Rev 01 board. The only difference is, that you should set the HFXO CTUNE value to 0 in InitDevice.c.

 

Best Regards,

Arnold

Posts: 3
Registered: ‎04-21-2017

Re: Can't find board/part in project setup

dear Arnold,

maybe I need some more help, indeed I couldn't find the declaration HFXO CTUNE in InitDevice.c, I attach the source.

best regards,

Luca

Posts: 2,368
Registered: ‎09-01-2015

Re: Can't find board/part in project setup

At the end of this thread there are detailed instructions how to use BGM111 rev01 with Studio v4:

http://community.silabs.com/t5/Bluetooth-Wi-Fi/BGM-111-Not-able-to-load-software-examples-from-SDK/m...

 

It also shows where to put the ctune setting. Remember to remove these additional settings when working with BGM111 v1.1 or later, it is only applicable to v1 revision.

Posts: 3
Registered: ‎04-21-2017

Re: Can't find board/part in project setup

it works!!

thank you,

Luca