Reply
Posts: 6
Registered: ‎03-20-2017

BLE112 Spp over BLE Application - general questions.

Hi,

 

I'am currently working with the bluegiga BLE112 Bluetooth low energy module and having some problems in commuicating with the device. My module is connected via the USART 1 with alternate 1 Funktion so that the Pins P0_5 and P_4  are used as RX and TX with internal pullup. The reset pin is continously at supply voltage since reset is aktive low. I established a serial connection with a Baud Rate of 115200.

 

Actually i assume that sending the "AT" command (Form: "AT \r\n") should result in OK response at the TX pin, or at least in an Errn if the command is not recognized.

I can measure the command input at the BLE112 RX pin but i dont get any response at the TX pin. Is the Response of the BLE112 transferred via the TX pin, did i generally missunderstood something or is my command format wrong?

 

I woudl be glad if i can get some help with this.


Best regards and thank you for your Help

 

Posts: 343
Registered: ‎10-07-2015

Re: BLE112 Spp over BLE Application - general questions.

Hello,

 

BLE module (which works as cable replacement) does not respond to commands itself - it only transfers the data to the Bluetooth link. It is the remote end (the device that BLE112 is connected to via Bluetooth) which is supposed to give "OK" (or other) response, not our module.

 

Regards,

Bartosz

Highlighted
Posts: 6
Registered: ‎03-20-2017

Re: BLE112 Spp over BLE Application - general questions.

Hello,


thank you for your reply. Actually i dont want to use the BLE module as cable replacement. I just configured my UART to communicate with the BLE Module's Uart 1 alt 1 (sending Commands and so on). Acutally i also tryed BGAPI command format, aswell as communicating with the BLE112 Module over the BLEGUI software interface using an external UART without microcontroller and a Baud Rate of 57600.

I still get no response from my Module (no output measurable at BLE112 TX pin).

I checked the hardware setup of the Module multiple times (design checklist). This seems to be ok.

 

I dont know whats wrong.

 

Thank you for your help

Posts: 343
Registered: ‎10-07-2015

Re: BLE112 Spp over BLE Application - general questions.

Could you please provide us your project?

 

Regards,

Bartosz

Posts: 6
Registered: ‎03-20-2017

Re: BLE112 Spp over BLE Application - general questions.

Hello,

 

actually there does not exist a real project. I got a Board with BLE112 module soldered on. First thing i wanted to do is check weather i can get a response from BLE112 Module when sending for example info command using Bluegiga BLE Graphical User Interface tool. Therefore i use an external USB powerd UART with Baud Rate of 57600 attatched to the BLEGUI software. I interrupted the TX, RX, CTS and RTS connections from BLE112 module to the on board Kinetis processor to just test communication over the UART. I can measure input commands at the RX pin of BLE112 Module but no response is provided.


Therefore I assume the person who created the hardware potentially did not flash the device appropriately. Do you know wheather there is a specific default config flashed onto BLE112?

 

Best regards

 

 

Posts: 343
Registered: ‎10-07-2015

Re: BLE112 Spp over BLE Application - general questions.

Hello,

 

The default project in BLE112 should be uartdemo. Note that in this project, sleep mode is enabled by default (that might be the reason, why you don't see any output). In order to communicate with the module in such case, you should:

- set wake up pin (P0.0 / button 1 on the development kit) high,

or

- disable sleep mode in hardware.xml file (simply add the following line: <sleep enable="false"/>).

 

 

Regards,

Bartosz

Posts: 6
Registered: ‎03-20-2017

Re: BLE112 Spp over BLE Application - general questions.

Thank you,

 

that was the Infromation I needed. It should be possible to deaktivate sleep mode by flashing the device via USART with edited hardware.xml file.

 

Best Regards,

 

Chelios