Posts: 14
Registered: ‎11-29-2016

EFM8SB Kit Error Segger



I'm trying the EFM8SB demo Kit but I can't program my demo kit board. I got this error:


"EFM8(C2): Connect failed and connected J-Link(S/N 440070545) not support fallback method (firmware too old). Please get in touch with Segger"


Could anyone help me?

Posts: 2,384
Registered: ‎10-14-2014

Re: EFM8SB Kit Error Segger

[ Edited ]



I don't fully understand your issue, do you mean you are try to program the MCU on the Silabs EFM8 STK board, or you want to program externally MCU on you own board with the EFM8 STK.


I checked some issues reported by other customer in our salesforce system with keyword "not support fallback method", I got 2 tickets and both looks finally they are hardware issue on the target board.


Hope this helps and you could double check if there is some hardware issue on your board.

Posts: 14
Registered: ‎11-29-2016

Re: EFM8SB Kit Error Segger

Hi again,


Yes, I'm programming the MCU on the Silabs EFM8 STK board with the firmware examples. This is the error window:




I wish It can be solved instead of a hardware problem...


Best regards,



Posts: 344
Registered: ‎09-22-2009

Re: EFM8SB Kit Error Segger

You might want to make sure that Simplicity Studio is fully updated, and then try to update the firmware of the debug adapter on the board. If there's new firmware available, this should be an option if you look at the board under the Devices tab and then find the spot where it says Adapter Firmware Version. 


You might also try fully resetting the debug adapter using the steps in this KB article:


Otherwise, new hardware may be required.

Posts: 4
Registered: ‎06-12-2017

Re: EFM8SB Kit Error Segger

Manuel, were you able to solve your issue?


I have exactly the same error. I have tried updating the firmware. The process succeeds, but then the error arises again. I used the boot test point to force the kit to halt in the bootloader as explained  in the last comment ( but the error persists.

I also tried upgrading the Simplicity Studio, but there are errors updating:

  • Segger J-Link Adapter Pack 4.0.7
  • Simplicity energy profiler for EFM8 - 4.0.5

among others.


Any ideas on what to do? My STK2010A kit is absolutely blocked.