Reply
Posts: 135
Registered: ‎12-06-2016

Strange behave of results of EFR32 / BGM113

I have a strange result from the ADC:

Help wellcome.

 

Vref = EXT 1.25 V

SINGLEOFFSET = 0x8

SINGLEOFFSETINV = 0xA

SINGLEGAIN = 0x00

 

Problems:

1. From 0,625 to 1.25 OK.   < 0.625 V allways 2048 ?!?

2. can't calibrate gain to 4096 mostly to 4079....4081

 

SINGLECTRLX - VREFSEL = 2

                            VREFATTFIX = 0

                            VREFFATT = 8

                            VINATT = 14

                            DVL = 0

                           FIFOOFACT = 1

                          PRSMODE = 0

                          PRSSEL = 0

SINGLECTRL  - REP = 0

                           DIFF = 0

                           ADJ = 0

                           RES = 3

                          REF = 7

                           POSSEL = 0x87

                           NEGSEL = 0xFF

                          AT = 5

                         PRSEN = 0

                         CMPEN = 0

 

CTRL  -  WARMUPMODE = 3

               SINGLEEDWAWU = 0

              SCANDMAWO = 0

              TAILGATE = 0

              ASYNCCLKEN = 0

             ADCCLKMODE = 0

             PRESC = 0

             TMEBASE = 5

             OVSRSEL = 6

             CHCONMODE = 0

 

 

 

 

 

 

Anybody any idea ?

Thanks

arnold

Posts: 306
Registered: ‎03-03-2015

Re: Strange behave of results of EFR32 / BGM113

Hi Arnold,

 

We have found this problem can occur when the ADC SAR clock exceeds its maximum specified frequency of 16MHz.  Since you have the prescaler set to 0 (divide by 1), depending on which oscillator you are using, you may be running the ADC out of spec.  Try changing the prescaler value and see if that addresses the problem.  Let me know if you have any questions.

 

Regards,

Joe

Posts: 3,021
Registered: ‎02-07-2002

Re: Strange behave of results of EFR32 / BGM113

Why was this topic (re)moved? It contains valuable information for anyone experiencing the same problem.

Posts: 540
Registered: ‎10-12-2004

Re: Strange behave of results of EFR32 / BGM113

Hi vanmierlo,

 

We agree that this thread should be in the 32-bit forum, so we're looking into why this was moved.

 

~Tabi

 

Tabitha Parker
Senior Manager of MCU and Micrium Applications
Silicon Laboratories
Highlighted
Posts: 540
Registered: ‎10-12-2004

Re: Strange behave of results of EFR32 / BGM113

This thread was originally deemed a duplicate, but since both now have replies, I've added this back to the 32-bit forum.  The duplicate thread is here:

 

http://community.silabs.com/t5/Bluetooth-Wi-Fi/Strange-behave-of-results-BGM113/m-p/193341/highlight...

 

~Tabi

Tabitha Parker
Senior Manager of MCU and Micrium Applications
Silicon Laboratories