Posts: 15
Registered: ‎03-08-2017
Accepted Solution

SEGGER JLink seems not support EFR32MG12P now

[ Edited ]

Hi Team,


I tried to flash EFR32MG12P Starter Kit dev board with the on-board integrated SEGGER JLink. However, it seems not work now and the connection to JLink always fails.


I checked the SEGGER JLink supported device name list from here, for EFR32MG12P, it should be "EFR32MG12PxxxF1024". However, when I try to connect to the JLink, it seems not work using that setting file, the detailed info as below. But the "EFR32MG1PxxxF256" allows to connect to JLink.


$ sudo ./JLinkGDBServer -if swd -device EFR32MG12PxxxF1024

SEGGER J-Link GDB Server V5.10j Command Line Version


JLinkARM.dll V5.10j (DLL compiled Feb  2 2016 19:32:23)


-----GDB Server start settings-----

GDBInit file:                  none

GDB Server Listening port:     2331

SWO raw output listening port: 2332

Terminal I/O port:             2333

Accept remote connection:      yes

Generate logfile:              off

Verify download:               off

Init regs on start:            off

Silent mode:                   off

Single run mode:               off

Target connection timeout:     0 ms

------J-Link related settings------

J-Link Host interface:         USB

J-Link script:                 none

J-Link settings file:          none

------Target related settings------

Target device:                 EFR32MG12PxxxF1024

Target interface:              SWD

Target interface speed:        1000kHz

Target endian:                 little


Connecting to J-Link...

J-Link is connected.

Failed to set device (EFR32MG12PxxxF1024). Unknown device selected?ERROR : Failed to set device.


Firmware: Silicon Labs J-Link Pro OB compiled Feb  8 2017 12:16:49

Hardware: V4.00

S/N: 440085383

Checking target voltage...

Target voltage: 3.36 V

Listening on TCP/IP port 2331

Connecting to target...ERROR: No CPU core or target device has been selected. Please make sure at least the core J-Link shall connect to, is selected.

ERROR: Could not connect to target.

Target connection failed. GDBServer will be closed...Restoring target state and closing J-Link connection...

Shutting down...

Could not connect to target.


I also attach a screenshot about the configuration page when I connected the EFR32MG12P dev boards to Simplicity Studio.


Please help have a check and correct me if i'm using the wrong device name.






Screen Shot 2017-04-13 at 10.42.58 AM.png

Posts: 561
Registered: ‎09-18-2015

Re: SEGGER JLink seems not support EFR32MG12P now

Hi @xiaom,


You are using an old version of the SEGGER JLink tools.


The current version is 6.14c.  Please upgrade.


We upgrade the JLinkARM.dll included with Simplicity Studio from release to release, which is why your Studio screenshot shows proper identification of the device as EFR32MG12. It includes a more recent version of JLinkARM.dll than the one you are trying to use with the GDB Server in the SEGGER package.



Posts: 15
Registered: ‎03-08-2017

Re: SEGGER JLink seems not support EFR32MG12P now

Yes, the latest GDB Server 6.14v works now. Thanks for this confirmation.