Posts: 242
Registered: ‎05-19-2014

Importing an existing project

I decided to click the box and update since it was offered in Simplicity Studio and really wish I hadn't. AVG decided there was a virus in it and deleted the offending files. After that I couldn't get it to connect so I uninstalled Simplicity Studio.

It said that the workspace wouldn't be deleted but it's now empty. I know where my project is, but I'm unsure how to get it back into the workspace without messing things up even further.

If I go to Project->Import then MCU project and navigate to my project folders, I can't see what file to select to load it. I'm presuming that the project information is stored there somewhere?


Maybe someone could tell me step by step how to get my project back into the Simplicity Studio workspace?



Posts: 242
Registered: ‎05-19-2014

Re: Importing an existing project

This is turning into yet another nightmare.... I found the knowledge base article on how to do this but it doesn't work.

I get this error...


An error has occurred. See error log for more details.
com.silabs.ide.internal.api.toolchain.core.IToolchainManager.getCompatible(Ljava/lang/StringRobot winkLcom/silabs/ide/internal/api/core/manager/IDescriptorEntity;


and when I go to try again, it says that I can't select the project because it's already in the workspace.... except it isn't there so I can't even delete it!


Maybe this problem is because the project was created with a later version of Simplicity Studio? Who knows.


The one I installed was the oldest one shown in the picture showing the download in that folder. I'm concerned that the latest one, the one that AVG thought was infected, is much larger than the others. Is this a genuine file and why does AVG dislike it?


I'm unsure if I should try to install it and allow it through the antivirus.

Any ideas where to go from here?

Posts: 242
Registered: ‎05-19-2014

Re: Importing an existing project

Ok, an uninstall and fresh install of Simplicity Studio has now solved all the problems. I guess AVG didn't like the way the updater appeared to behave.

Posts: 242
Registered: ‎05-19-2014

Re: Importing an existing project

I spoke too soon, Simplicity Studio connects through to my target board after I've told the energyAware Commander to go to 'Out' and it reports that it's programmimng flash.

It then hangs for about 40 seconds and eventually shows the run buttons. When I run the code and halt it, it's sitting on the following line...


def_irq_handler HardFault_Handler


which sounds ominous. I don't know if that's the starter kit hardware or mine. It's hard to imagine it's mine because there's so little of it, just the J-Link connector and a processor.

I don't understand what's changed. The hardware was the same as before the new install of Simplicity Studio so there's no reason to think the hardware is faulty. I've changed the processor on my simple project board and it makes no difference.


Does anyone know what's going on and what to try next?

Posts: 242
Registered: ‎05-19-2014

Re: Importing an existing project

I've been going round in circles and have established a few facts...

1) Installing an older version of Simplicity Studio won't allow my project to be imported.

2) Installing the latest version of Simplicity Studio does allow my project to  be imported.

3) The Blink example runs correctly on the EFM32WG-STK3800 starter kit, but of course that's on a different processor and on the board rather than through J-link

4) J-Link seems completely happy detecting my board and either of the two EFN32WG232F256 devices I plug in.

5) Everything seems normal about the debug build except that it hangs after the Flash programming dialog box closes.

6) Sometimes the run buttons return after a timeout of about 40 seconds, other times they remain greyed out.

7) If the run buttons return, the code always ends up on the line def_irq_handler HardFault_Handler when halted ie, I don't think it ever runs.

8) I tried another Starter board, this time a Tiny Gecko one and I ignored the warnings that it wasn't smart enough since it said I could use it. That gave the same results as the WG starter kit board.

9) I've gone over my simple project breadboard with a fine toothed comb and can't find anything wrong there.

10)I can see that both .axf and .obj files are being generated by this version, the .obj wasn't being generated on the version I had before.

11) When I recompile, it comes up with the Device Busy dialog box as usual and asks if I want to restart debugging. I always say yes. It then starts the flashing process but doesn't generate any error messages.


I've attached a picture of the dialog box as it's cleaning the workspace and I'm not sure if it's right. The second progress bar gets to about half way and then the whole process finishes. The bottom progress bar shows it's blocked by background processes. It's probably just that those two progress bars complete almost instantly the first one is done, but I thought I'd mention it in case it's significant.


It's hard to be certain what's wrong because I don't have another WG starter kit to try or another breadboard. My gut feeling is that it's a firmware issue with the upgrade but I can't prove that.

Is anyone else having this issue?

Posts: 242
Registered: ‎05-19-2014

Re: Importing an existing project

So this morning I've uninstalled and re-installed the Segger J-link driver and nothing has changed. I've notice before when using the debugger, that there's always a pause between the end of the flashing process and the return of the Run buttons from their greyed out state. That's where the problem lies, whatever it's doing there.


I downloaded Simplicity Studio onto an almost identical computer and that won't even connect to the chip on the Starter Kit although it does recognise that the starter kit is connected. What that means is anyone's guess. Bringing the same board back to my main computer and it still shows the symptoms I've described.

Posts: 123
Registered: ‎09-15-2013

Re: Importing an existing project

From your posts, this sounds really bad.... 


I have been deathly afraid of switching to the new Eclipse-based IDE since we've been using IAR since the beginning.  


Although there's the 32k code-size limit, and the price is pretty steep for a full seat, it seems like it's worth it to pick up an IDE that 'just works'.


You might want to just give IAR a try to get over all the outstanding issues with your IDE?

Posts: 529
Registered: ‎08-07-2012

Re: Importing an existing project

Sorry to hear you are having so many problems. But I believe the error you are seeing now is just because of a misconfigured project. If you end up in the hardfault handler something went horribly wrong on the MCU, it is not necessarily related to the debugger. 


Check that your project is configured for the right part: 

 * check that the correct startup files are used (e.g. startup_gcc_efm32wg.s and system_efm32wg.c for WG). 

 * check that you have the correct include paths

 * check that the correct part number is defined in the preprocessor 'symbols' section. 


In your debug configuration, uncheck the 'run from reset' checkbox to halt the CPU at the reset handler. Then you can step through and find out when you end up in hardfault, before getting to main. 


You can also try to create a new project (using the energyAware Designer) and then drag in your files when you have the project working.  

Posts: 242
Registered: ‎05-19-2014

Re: Importing an existing project

Other than this issue, it's not been too bad. I have had one Starter Kit pack up though for no good reason. I don't think the hardware is very robust when debugging a target board through the J-link header. Maybe I've just been unlucky. This may prove to be a similar problem, I've got yet another starter kit on order to try out. They're rather expensive fuses though if this proves to be a recurring problem!

In my experience it's no worse an environment than Microchips MPLAB-X which I abandoned for this project partly because it was hopelessly broken for the chip I was trying to use. In my opinion, all these system are temperamental and flaky.

Posts: 242
Registered: ‎05-19-2014

Re: Importing an existing project

Thanks for that Chris, I'll take a deep breath and try out those things. It just seems odd that the default fresh install didn't work on my other computer but has a different problem. It's the same project but it won't run in the new version. I hope you're right and it's just a configuration issue. I'll report back my findings one way or the other.

Posts: 242
Registered: ‎05-19-2014

Re: Importing an existing project

Ok, here's what I've done.
I've uninstalled Simplicity Studio and searched the registry for every occurrence of the word 'Simplicity' and removed about 20 orphaned references that weren't uninstalled. I searched for 'Eclipse' amd found nothing.
I've then deleted the Simplicity Studio folder and removed all references to Simplicity Studio in the Appdata etc, anywhere where there was a reference found by a windows search.
I also uninstalled J-link and there was another driver installed but I don't recall the name. Anyway, if it's required it will install it again.
I think that's about as clean as I can get it unless you know of something else lurking under a different name.
I also uninstalled MPLAB-X because there was a hint that eclipse might have been involved in that system somewhere and I didn't want any conflicts.
I've gone to the download page and used the latest version of Simplicity Studio for a completely fresh install.
The install prompted for both the J-link and also the CP210x USB to UART Bridge Driver so I guess that's the one I uninstalled.
There's a change to the problem, it hangs at 82% on the Launching progress at the bottom right of the Simplicity Studio screen.
Clicking on the little box in the far corner, it pops up the progress screen which says...
Launching: Configuring SLS Debugger: Find or Launch TCF peer
that's where it's stuck at 82%. Clicking to abort it doesn't work, you have to close the Studio. Closing it isn't enough to halt the processs, it restarts and shows it's still stuck at 82%
Having restarted it, it then compiled and said it was flashing the program as before, but again, it didn't un-grey the run icons so I can't run it.
The new WG starter kit has just arrived and it shows the same problem, so this is definitely a software issue.
The project was built using energyAware Designer.

I've just created a project from scratch using the energyAware designer with nothing selected. I clicked 'update project' and it's created an empty project. It shows exactly the same problems so it has nothing to do with my project files. This has to be an issue with whatever the software is doing immediately before it starts the debugging session.

I've just noticed that the icons have just lit up, presumably there was a timeout somewhere. Closing all the windows and clicking restart it's showing me startup_gcc_efm32wg.s and the active line being the first one of the Reset_Handler function. Pressing Run makes it run, and pausing it shows it's on the HardFault_Handler again.


I'm getting pretty desperate now, I really need a solution to this ASAP


Here's a screen shot of the last thing it does before it freezes. There are no errors reported anywhere.

Posts: 242
Registered: ‎05-19-2014

Re: Importing an existing project

I've just built a second simple target board that has just the power and ground connections to the appropriate pins on the EFM32WG232 chip and the decoupling capacitors. I've fitted a 20way connector for the J-link, hooked up all the ground connections and the VCC plus the SWIO, SCLK, SWO and RESET. I've also made a new ribbon cable just in case that was faulty.


This shows all the same issues I've described before.


So, to recap.....


1) Everything was working fine, debugging my target board on the old version of Simplicity Studio but it didn't produce the .bin file I needed to flash the project and make it stand alone.

2) I Upgraded to the latest Simplicity Studio and have since done a complete reinstallation of that and the USB and J-Link drivers and it doesn't work any more. NB:- No hardware changes were made during this time.

3) I've done a clean installation on another computer and that doesn't work either.

4) I've bought a new Starter Kit, made a new target board and a new cable and it still has the same problem.


My conclusion is that there's something wrong with the drivers that flash the target board and get it into debug mode


That leaves me completely stuck without some kind of assistance.


Posts: 242
Registered: ‎05-19-2014

Re: Importing an existing project

Filip, you're raised a support ticket but I can't access it because I didn't have an account. I've created one now using the email address the ticket notice was sent to but the ticket doesn't appear to be associated with that email address so I can't see it.


In answer to the points raised though.


No, I don't use a USB hub, it's a direct connection.

The other computer is also 65bit and a quad core,3GHz


Posts: 242
Registered: ‎05-19-2014

Re: Importing an existing project

This looks like a problem with a driver. I've managed to flash the chip on the breadboard using the energyAware commander and that seems fine.

I'm not that surprised really, the dialog box that displays progress when the program is being flashed always goes out before the system hangs so it's whatever happens after that which has the issue.


I've now downloaded the IAR development suite and that's happy to connect to my breadboard, program the target and single step.


This is only a very recent issue that came about when I upgraded to the latest version. Something has clearly been modified in that upgrade that has caused this issue. Hopefully someone can look back at what was changed and reverse whatever has caused this problem. Doing that very quickly would be a big help, that's four days wasted so far.

Posts: 242
Registered: ‎05-19-2014

Re: Importing an existing project

Ok, here's the conclusion to this long saga....


It would appear that upgrading somehow requires the following line to be added to the end of the command in the three sections for the Compiler, Assembler and Linker.




I've added screenshots of what these need to be, not forgetting to do that for both Debug and Release build properties.

This has something to do with the maths functions. I have no idea why this is required since the project compiled fine for the whole of the preceding month before the upgrade. I would have thought that the properties would have been embedded with the rest of the project build files. Maybe it's a change to the maths libraries, who knows.

There's a bug in the energyAware designer which doesn't create these necessary lines commands, and that's why it wouldn't work even when creating an empty project.


Anyway, my thanks go to Filip who figured out what the problem was and got me going again. I'm surprised that I appear to be the only one with this issue. Maybe I'm the only one using the latest version of Simplicity Studio with a remote target and J-link.


Posts: 29
Registered: ‎09-09-2013

Re: Importing an existing project

I just went through all of this myself. It was terrible. I finally got mine working by creating the new project and porting my design over to it.

Posts: 8,134
Registered: ‎08-13-2003

Re: Importing an existing project

while, obviously, the implementation is clumsy, I love that the so often abused float is optional.  Why does the need for 3.2 automatically, in so manys mind, mean float